Thursday, January 19, 2012

How to Install iOS5 on iPhone 2G and iPod Touch 1G

iPhone and iPod Touch users might not have much to complain about system updates from Apple. Unlike other platforms, where devices are launched with outdated system versions, and support seems lacking even for devices barely a year old; with iPhones, users have grown accustomed to have official support and updates for a long time.

That's not to say that inevitably, older devices just can't keep up with the system improvements - even though sometimes some limitations are deliberately put in place by Apple, like not having Siri on the iPhone - which means that iPhone 2G and the original iPod Touch users have been left behind when iOS5 came out.

But... if you're still patient enough to be using one of those devices (let me tell you, I really admire you if you do) now you can try iOS5 on the iPhone 2G and iPod Touch 1st Gen thanks to this Whited00r.

I wouldn't expect it to work wonders for your device... but if you're tired of finding Apps that refuse to work in older iOS... this might buy some extra time before upgrading to a newer iDevice.

2 comments:

  1. That was a nice piece of information of vehicle insurance... cleared much of my doubts

    ReplyDelete

Related Posts with Thumbnails

Amazon Store